logon problem

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

logon problem

Sean Kirkpatrick
QuickFIX Documentation: http://www.quickfixengine.org/quickfix/doc/html/index.html
QuickFIX FAQ: http://www.quickfixengine.org/wikifix/index.php?QuickFixFAQ
QuickFIX Support: http://www.quickfixengine.org/services.html

Hello All,

I've encountered a bizarre logon problem (1.9.4).  A session was logged
in and functioning normally (heartbeats, new orders, exec rpts, etc).  
The connection was then brought down without logging off.  I increased
the seq number to test the sequence reset functionality, but now the server
doesn't even see the logon request.  I was able to verify that the message
is coming across using a packet sniffer, but quickfix is not logging
anything to any of the session logs (incoming, outgoing, event).  On the
initiator, all I see is:

20050623-18:36:19 : Connecting to host on port #
20050623-18:36:19 : Connection succeeded
20050623-18:36:19 : Initiated logon request
20050623-18:36:19 : Dropped Connection

I've checked to ensure that the Comp IDs are correct as well as the FIX
version.  I am able to log in and use other sessions normally from the same
test app.  Is there anything that might cause an individual session to
become mangled?

Thanks,
Sean


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. <a href="http://ads.osdn.com/?ad_idt77&alloc_id492&op=click">http://ads.osdn.com/?ad_idt77&alloc_id492&op=click
_______________________________________________
Quickfix-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quickfix-developers
Reply | Threaded
Open this post in threaded view
|

Re: logon problem

Alvin Wang

Sean,

Are you saying that you got a Logout from counterparty but QF did not log it anywhere? I think I saw it also.

Alvin



"Sean Kirkpatrick" <[hidden email]>
Sent by: [hidden email]

06/23/2005 02:47 PM

       
        To:        <[hidden email]>
        cc:        
        bcc:        
        Subject:        [Quickfix-developers] logon problem



QuickFIX Documentation: http://www.quickfixengine.org/quickfix/doc/html/index.html
QuickFIX FAQ: http://www.quickfixengine.org/wikifix/index.php?QuickFixFAQ
QuickFIX Support: http://www.quickfixengine.org/services.html

Hello All,

I've encountered a bizarre logon problem (1.9.4).  A session was logged
in and functioning normally (heartbeats, new orders, exec rpts, etc).  
The connection was then brought down without logging off.  I increased
the seq number to test the sequence reset functionality, but now the server
doesn't even see the logon request.  I was able to verify that the message
is coming across using a packet sniffer, but quickfix is not logging
anything to any of the session logs (incoming, outgoing, event).  On the
initiator, all I see is:

20050623-18:36:19 : Connecting to host on port #
20050623-18:36:19 : Connection succeeded
20050623-18:36:19 : Initiated logon request
20050623-18:36:19 : Dropped Connection

I've checked to ensure that the Comp IDs are correct as well as the FIX
version.  I am able to log in and use other sessions normally from the same
test app.  Is there anything that might cause an individual session to
become mangled?

Thanks,
Sean


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_idt77&alloc_id492&op=click
_______________________________________________
Quickfix-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quickfix-developers


********************************************************************** This e-mail message is intended solely for the use of the addressee. The message may contain information that is privileged and confidential. Disclosure to anyone other than the intended recipient is prohibited. If you are not the intended recipient, please do not disseminate, distribute or copy this communication, by e-mail or otherwise. Instead, please notify us immediately by return e-mail (including the original message with your reply) and then delete and discard all copies of the message. We have taken precautions to minimize the risk of transmitting software viruses but nevertheless advise you to carry out your own virus checks on any attachment to this message. We accept no liability for any loss or damage caused by software viruses. **********************************************************************
Reply | Threaded
Open this post in threaded view
|

RE: logon problem

Sean Kirkpatrick
In reply to this post by Sean Kirkpatrick
QuickFIX Documentation: http://www.quickfixengine.org/quickfix/doc/html/index.html
QuickFIX FAQ: http://www.quickfixengine.org/wikifix/index.php?QuickFixFAQ
QuickFIX Support: http://www.quickfixengine.org/services.html

There was a hard failure on the client side (no logout message was sent,
so the connection was just dropped).  I've been investigating further and
it seems like the socket was not shut down properly.  I was able to
recreate this behavior by logging on to a session (establishing the
socket connection) and then attempting to log in to the same session with
another client app.  The second app gets dropped immediately.

--Sean

-----Original Message-----
From: Alvin Wang [mailto:[hidden email]]
Sent: Friday, June 24, 2005 4:17 AM
To: Sean Kirkpatrick
Cc: [hidden email]; [hidden email]
Subject: Re: [Quickfix-developers] logon problem



Sean,

Are you saying that you got a Logout from counterparty but QF did not log it anywhere? I think I saw it also.

Alvin



"Sean Kirkpatrick" <[hidden email]>
Sent by: [hidden email]
06/23/2005 02:47 PM
       
        To:        <[hidden email]>
        cc:        
        bcc:        
        Subject:        [Quickfix-developers] logon problem



QuickFIX Documentation: http://www.quickfixengine.org/quickfix/doc/html/index.html
QuickFIX FAQ: http://www.quickfixengine.org/wikifix/index.php?QuickFixFAQ
QuickFIX Support: http://www.quickfixengine.org/services.html

Hello All,

I've encountered a bizarre logon problem (1.9.4).  A session was logged
in and functioning normally (heartbeats, new orders, exec rpts, etc).  
The connection was then brought down without logging off.  I increased
the seq number to test the sequence reset functionality, but now the server
doesn't even see the logon request.  I was able to verify that the message
is coming across using a packet sniffer, but quickfix is not logging
anything to any of the session logs (incoming, outgoing, event).  On the
initiator, all I see is:

20050623-18:36:19 : Connecting to host on port #
20050623-18:36:19 : Connection succeeded
20050623-18:36:19 : Initiated logon request
20050623-18:36:19 : Dropped Connection

I've checked to ensure that the Comp IDs are correct as well as the FIX
version.  I am able to log in and use other sessions normally from the same
test app.  Is there anything that might cause an individual session to
become mangled?

Thanks,
Sean


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. <a href="http://ads.osdn.com/?ad_idt77&alloc_id492&op=click">http://ads.osdn.com/?ad_idt77&alloc_id492&op=click
_______________________________________________
Quickfix-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quickfix-developers


********************************************************************** This e-mail message is intended solely for the use of the addressee. The message may contain information that is privileged and confidential. Disclosure to anyone other than the intended recipient is prohibited. If you are not the intended recipient, please do not disseminate, distribute or copy this communication, by e-mail or otherwise. Instead, please notify us immediately by return e-mail (including the original message with your reply) and then delete and discard all copies of the message. We have taken precautions to minimize the risk of transmitting software viruses but nevertheless advise you to carry out your own virus checks on any attachment to this message. We accept no liability for any loss or damage caused by software viruses. **********************************************************************


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. <a href="http://ads.osdn.com/?ad_idt77&alloc_id492&op=click">http://ads.osdn.com/?ad_idt77&alloc_id492&op=click
_______________________________________________
Quickfix-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quickfix-developers