Quantcast

make with python failing.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

make with python failing.

Timothy Appnel
QuickFIX Documentation: http://www.quickfixengine.org/quickfix/doc/html/index.html
QuickFIX Support: http://www.quickfixengine.org/services.html


I'm trying to compile quickfix-1.13.3 with python support and hitting an error while doing a make. I was wondering if anyone had seen this before and could offer some advice for getting around it.

Environment: Ubuntu 13.04

$ sudo aptitude install g++ automake libtool libxml2 libxml2-dev xsltproc make python python-devel git

I've tried building from the github repo and a tar ball with the same result. 

$ ./bootstrap
$ ./configure --with-python=/usr/include/python2.7
$ make

I've attached the full output of the configure and make but here is where things go wrong during the make:

Making all in python
make[3]: Entering directory `/home/ubuntu/tmp/quickfix-1.13.3/src/python'
/bin/bash ../../libtool --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I. -I../.. -I. -I.. -I../..    -g -O2 -Wall -ansi -Wpointer-arith -Wwrite-strings     -I/usr/include/libxml2  -I/usr/include/python2.7  -MT QuickfixPython.lo -MD -MP -MF .deps/QuickfixPython.Tpo -c -o QuickfixPython.lo QuickfixPython.cpp
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../.. -I. -I.. -I../.. -g -O2 -Wall -ansi -Wpointer-arith -Wwrite-strings -I/usr/include/libxml2 -I/usr/include/python2.7 -MT QuickfixPython.lo -MD -MP -MF .deps/QuickfixPython.Tpo -c QuickfixPython.cpp  -fPIC -DPIC -o .libs/QuickfixPython.o
QuickfixPython.cpp: In function 'void SWIG_Python_AddErrorMsg(const char*)':
QuickfixPython.cpp:872:42: warning: format not a string literal and no format arguments [-Wformat-security]
QuickfixPython.cpp: In function 'PyObject* _wrap_DataDictionary_getGroup(PyObject*, PyObject*)':
QuickfixPython.cpp:306005:9: warning: unused variable 'res' [-Wunused-variable]
g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.6/README.Bugs> for instructions.
make[3]: *** [QuickfixPython.lo] Error 1
make[3]: Leaving directory `/home/ubuntu/tmp/quickfix-1.13.3/src/python'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/ubuntu/tmp/quickfix-1.13.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ubuntu/tmp/quickfix-1.13.3'
make: *** [all] Error 2

Everything compiles fine without the python option. So I'm pretty sure its something in the python bindings, the question is why. 

I found this thread, but it doesn't seem to be the same thing because I can't get past the make step.


Any guesses to what's going wrong here on me?

<tim/>

------------------------------------------------------------------------------

_______________________________________________
Quickfix-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quickfix-developers

make.log (80K) Download Attachment
configure.log (9K) Download Attachment
Loading...